Halaman

Senin, 24 Juni 2013

Laporan
Lab 4.4.1: Basic VTP Configuration


Nama    : Markhamah Tri Utami
NIM      : 12 615 056


Learning Objectives
  • Perform basic switch configurations
  • Configure the Ethernet interfaces on the host PCs
  • Configure VTP and security on the switches

Task 1: Perform Basic Switch Configurations
Configure the S1, S2, and S3 switches according to the following guidelines and save all your configurations:
Configure the switch hostname as indicated on the topology.
Disable DNS lookup.
Configure an EXEC mode password of class.
Configure a password of cisco for console connections.
Configure a password of cisco for vty connections.
Switch>enable
Switch#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#hostname S1
S1(config)#enable secret class
S1(config)#no ip domain-lookup
S1(config)#line console 0
S1(config-line)#password cisco
S1(config-line)#login
S1(config-line)#line vty 0 15
S1(config-line)#password cisco
S1(config-line)#login
S1(config-line)#end
S1#copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]

Task 2: Configure the Ethernet Interfaces on the Host PCs

      Configure the Ethernet interfaces of PC1, PC2, PC3, PC4, PC5, and PC6 with the IP addresses and default gateways indicated in the addressing table.
Task 3: Configure VTP and Security on the Switches

Step 1. Enable the user ports on S2 and S3.

Configure the user ports in access mode. Refer to the topology diagram to determine which ports are connected to end-user devices.
S2(config)#interface fa0/6
S2(config-if)#switchport mode access
S2(config-if)#no shutdown
S2(config-if)#interface fa0/11
S2(config-if)#switchport mode access
S2(config-if)#no shutdown
S2(config-if)#interface fa0/18
S2(config-if)#switchport mode access
S2(config-if)#no shutdown


Step 2. Check the current VTP settings on the three switches.
Use the show vtp status command to determine the VTP operating mode for all three switches.
S1#show vtp status
VTP Version                     : 2
Configuration Revision          : 0
Maximum VLANs supported locally : 64
Number of existing VLANs        : 5
VTP Operating Mode              : Server
VTP Domain Name                 : 
VTP Pruning Mode                : Disabled
VTP V2 Mode                     : Disabled
VTP Traps Generation            : Disabled
MD5 digest                      : 0x7D 0x5A 0xA6 0x0E 0x9A 0x72 0xA0 0x3A 
Configuration last modified by 0.0.0.0 at 0-0-00 00:00:00
Local updater ID is 0.0.0.0 (no valid interface found)
 
S2#show vtp status
VTP Version                     : 2
Configuration Revision          : 0
Maximum VLANs supported locally : 64
Number of existing VLANs        : 5
VTP Operating Mode              : Server
VTP Domain Name                 : 
VTP Pruning Mode                : Disabled
VTP V2 Mode                     : Disabled
VTP Traps Generation            : Disabled
MD5 digest                      : 0x7D 0x5A 0xA6 0x0E 0x9A 0x72 0xA0 0x3A 
Configuration last modified by 0.0.0.0 at 0-0-00 00:00:00
Local updater ID is 0.0.0.0 (no valid interface found)
 
S3#show vtp status
VTP Version                     : 2
Configuration Revision          : 0
Maximum VLANs supported locally : 64
Number of existing VLANs        : 5
VTP Operating Mode              : Server
VTP Domain Name                 : 
VTP Pruning Mode                : Disabled
VTP V2 Mode                     : Disabled
VTP Traps Generation            : Disabled
MD5 digest                      : 0x7D 0x5A 0xA6 0x0E 0x9A 0x72 0xA0 0x3A 
Configuration last modified by 0.0.0.0 at 0-0-00 00:00:00
Local updater ID is 0.0.0.0 (no valid interface found)
VTP allows the network administrator to control the instances of VLANs on the network by creating VTP domains. Within each VTP domain, one or more switches are configured as VTP servers. VLANs are then created on the VTP server and pushed to the other switches in the domain. Common VTP configuration tasks are setting the operating mode, domain, and password. Note that all three switches are in server mode. Server mode is the default VTP mode for most Catalyst switches. In this activity, you will be using S1 as the VTP server, with S2 and S3 configured as VTP clients or in VTP transparent mode.

Step 3. Configure the operating mode, domain name, and VTP password on all three switches.

Set the VTP domain name to Lab4 and the VTP password to cisco on all three switches. Configure S1 in server mode, S2 in client mode, and S3 in transparent mode.
S1(config)#vtp mode server
Device mode already VTP SERVER.
S1(config)#vtp domain Lab4
Changing VTP domain name from NULL to Lab4
S1(config)#vtp password cisco
Setting device VLAN database password to cisco
S1(config)#end 
 
S2(config)#vtp mode client
Setting device to VTP CLIENT mode
S2(config)#vtp domain Lab4
Changing VTP domain name from NULL to Lab4
S2(config)#vtp password cisco
Setting device VLAN database password to cisco
S2(config)#end 
 
S3(config)#vtp mode transparent
Setting device to VTP TRANSPARENT mode.
S3(config)#vtp domain Lab4
Changing VTP domain name from NULL to Lab4
S3(config)#vtp password cisco
Setting device VLAN database password to cisco
S3(config)#end 
Note: The VTP domain name can be learned by a client switch from a server switch, but only if the client switch domain is in the null state. It does not learn a new name if one has been previously set. For that reason, it is good practice to manually configure the domain name on all switches to ensure that the domain name is configured correctly. Switches in different VTP domains do not exchange VLAN information.

Step 4. Configure trunking and the native VLAN for the trunking ports on all three switches.

On all switches, configure trunking and the native VLAN for FastEthernet interfaces 0/1-5. Only commands for fa0/1 on each switch are shown below.
S1(config)#interface fa0/1
S1(config-if)#switchport mode trunk
S1(config-if)#switchport trunk native vlan 99
S1(config-if)#no shutdown
S1(config-if)#interface fa0/2
S1(config-if)#switchport mode trunk
S1(config-if)#switchport trunk native vlan 99
S1(config-if)#no shutdown
S1(config-if)#end
 
S2(config)#interface fa0/1
S2(config-if)#switchport mode trunk
S2(config-if)#switchport trunk native vlan 99
S2(config-if)#no shutdown
S2(config-if)#end
 
S3(config)#interface fa0/2
S3(config-if)#switchport mode trunk
S3(config-if)#switchport trunk native vlan 99
S3(config-if)#no shutdown
S3(config-if)#end

Step 5. Configure port security on the S2 and S3 access layer switches.

Configure ports fa0/6, fa0/11, and fa0/18 so that they allow only a single host and learn the MAC address of the host dynamically.
S2(config)#interface fa0/6
S2(config-if)#switchport port-security 
S2(config-if)#switchport port-security maximum 1
S2(config-if)#switchport port-security mac-address sticky 
S2(config-if)#interface fa0/11
S2(config-if)#switchport port-security 
S2(config-if)#switchport port-security maximum 1
S2(config-if)#switchport port-security mac-address sticky 
S2(config-if)#interface fa0/18 
S2(config-if)#switchport port-security 
S2(config-if)#switchport port-security maximum 1
S2(config-if)#switchport port-security mac-address sticky 
S2(config-if)#end
 
S3(config)#interface fa0/6
S3(config-if)#switchport port-security 
S3(config-if)#switchport port-security maximum 1
S3(config-if)#switchport port-security mac-address sticky 
S3(config-if)#interface fa0/11
S3(config-if)#switchport port-security 
S3(config-if)#switchport port-security maximum 1
S3(config-if)#switchport port-security mac-address sticky 
S3(config-if)#interface fa0/18 
S3(config-if)#switchport port-security 
S3(config-if)#switchport port-security maximum 1
S3(config-if)#switchport port-security mac-address sticky 
S3(config-if)#end

Step 6. Configure VLANs on the VTP server.

There are four VLANS required in this lab:
  • VLAN 99 (management)
  • VLAN 10 (faculty/staff)
  • VLAN 20 (students)
  • VLAN 30 (guest)
Configure these on the VTP server. Packet Tracer grading is case-sensitive.
S1(config)#vlan 99
S1(config-vlan)#name management
S1(config-vlan)#exit
S1(config)#vlan 10
S1(config-vlan)#name faculty/staff
S1(config-vlan)#exit
S1(config)#vlan 20 
S1(config-vlan)#name students
S1(config-vlan)#exit
S1(config)#vlan 30
S1(config-vlan)#name guest
S1(config-vlan)#exit
Verify that the VLANs have been created on S1 with the show vlan brief command.

Step 7. Check if the VLANs created on S1 have been distributed to S2 and S3.

Use the show vlan brief command on S2 and S3 to determine if the VTP server has pushed its VLAN configuration to all the switches.
S2#show vlan brief
 
VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/1, Fa0/2, Fa0/4, Fa0/5
                                                Fa0/6, Fa0/7, Fa0/8, Fa0/9
                                                Fa0/10, Fa0/11, Fa0/12,Fa0/13
                                                Fa0/14, Fa0/15, Fa0/16,Fa0/17
                                                Fa0/18, Fa0/19, Fa0/20,Fa0/21
                                                Fa0/22, Fa0/23, Fa0/24, Gi0/1
                                                Gi0/2
10   faculty/staff                    active
20   students                         active
30   guest                            active
99   management                       active 
 
S3#show vlan brief
VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/1, Fa0/3, Fa0/4, Fa0/5
                                                Fa0/6, Fa0/7, Fa0/8, Fa0/9
                                                Fa0/10, Fa0/11, Fa0/12, Fa0/13
                                                Fa0/14, Fa0/15, Fa0/16, Fa0/17
                                                Fa0/18, Fa0/19, Fa0/20, Fa0/21
                                                Fa0/22, Fa0/23, Fa0/24, Gig1/1
                                                Gig1/2
1002 fddi-default                     active    
1003 token-ring-default               active    
1004 fddinet-default                  active    
1005 trnet-default                    active    
Are the same VLANs configured on all switches?
Why do S2 and S3 have different VLAN configurations at this point?

Step 8. Create a new VLAN on S2 and S3.

S2(config)#vlan 88
%VTP VLAN configuration not allowed when device is in CLIENT mode.
 
S3(config)#vlan 88
S3(config-vlan)#name test
S3(config-vlan)#
Why are you prevented from creating a new VLAN on S2 but not S3?
Delete VLAN 88 from S3.
S3(config)#no vlan 88

Step 9. Manually configure VLANs.

Configure the four VLANs identified in Step 6 on switch S3.
S3(config)#vlan 99
S3(config-vlan)#name management
S3(config-vlan)#exit
S3(config)#vlan 10
S3(config-vlan)#name faculty/staff
S3(config-vlan)#exit
S3(config)#vlan 20 
S3(config-vlan)#name students
S3(config-vlan)#exit
S3(config)#vlan 30
S3(config-vlan)#name guest
S3(config-vlan)#exit
Here you see one of the advantages of VTP. Manual configuration is tedious and error prone, and any error introduced here could prevent intra-VLAN communication. In addition, these types of errors can be difficult to troubleshoot.

Step 10. Configure the management interface address on all three switches.

S1(config)#interface vlan 99
S1(config-if)#ip address 172.17.99.11 255.255.255.0
S1(config-if)#no shutdown
S2(config)#interface vlan 99
S2(config-if)#ip address 172.17.99.12 255.255.255.0
S2(config-if)#no shutdown
S3(config)#interface vlan 99
S3(config-if)#ip address 172.17.99.13 255.255.255.0
S3(config-if)#no shutdown
Verify that the switches are correctly configured by pinging between them. From S1, ping the management interface on S2 and S3. From S2, ping the management interface on S3.
Were the pings successful? If not, troubleshoot the switch configurations and try again.

Step 11. Assign switch ports to VLANs.

Refer to the port assignment table at the beginning of the activity to assign ports to the VLANs. Since Packet Tracer 4.11 does not make use of the interface range command, only configure the first interface for each VLAN. Port assignments are not configured through VTP. Port assignments must be configured on each switch manually or dynamically using a VMPS server. The commands are shown for S3 only, but both S2 and S3 switches should be similarly configured. Save the configuration when you are done.
S3(config)#interface fa0/6
S3(config-if-range)#switchport access vlan 30
S3(config-if-range)#interface fa0/11
S3(config-if-range)#switchport access vlan 10
S3(config-if-range)#interface fa0/18
S3(config-if-range)#switchport access vlan 20
S3(config-if-range)#end
S3#copy running-config startup-config
Destination filename [startup-config]? [enter]
Building configuration...
[OK]
S3#

Hasil Praktikum
ping PC1 ke PC4

ping PC2 ke PC 5
ping PC3 ke PC 6






Minggu, 23 Juni 2013

Laporan Praktikum 
Lab 5.6.1: Basic RIP Configuration

Nama  : Markhamah Tri Utami
NIM    : 12 615 056  

Tujuan Praktikum 
-   Mahasiswa dapat mengetahui bagaimana cara  Verify RIP routing using show dan debug commands
-   Mahasiswa dapat melakukan observasi tentang RIP processing using the debug ip rip command.

Pendahuluan
Karakteristik RIPv1:
- RIPv1 merupakan distance vector routing protocol
- Max hop count:15. 16 -> unreachable
- Classful routing protocol
- Update dikirim secara broadcast(255.255.255.255)
- Periode update: 30s
- Paket yang dikirim berjenis UDP dengan nomor port 520
- Dapat mengirimkan paket update RIPv1 dan menerima paket update RIPv1 & v2
- Mendukung equal cost load balancing. Secara default adalah 4 path, sedang max path: 6
- Menjalankan auto-summary secara default
Langkah Praktikum
Topology Diagram



R1(config)#router rip
R1(config-router)#network 192.168.1.0
R1(config-router)#network 192.168.2.0
R1(config-router)#
R1#copy run start
Configure RIP on the R2 router using the router rip and network commands.
R2(config)#router rip
R2(config-router)#network 192.168.2.0
R2(config-router)#network 192.168.3.0
R2(config-router)#network 192.168.4.0
R2(config-router)#end
Configure RIP on the R3 router using the router rip and network commands.
R3(config)#router rip
R3(config-router)#network 192.168.4.0
R3(config-router)#network 192.168.5.0
R3(config-router)#end

R1#debug ip rip
Discontinue the debug output with the undebug all command.
R1#undebug all

Langkah Pertama
                  Konfigurasi skenario B hampir sama pada skenario A, akan tetapi di skenario B ini menyediakan IP yang sudah di subnetting otomatis untuk RIP pada skenario A diganti dengan IP yang sudah di subnetting caranya ada command di router menggunakan perintah "no ip route".
               Perintah tersebut berlaku pada ketiga router no ip route. No ip route   adalah perintah yang digunakan untuk menghapus ip route sebelumnya pada skenario ini kita disuruh menghentikan update ip pada setiap router command yang digunakan "passive-interface fastethernet0/0".
Langkah Kedua

 Melakukan test koneksi pada setiap router apakah sudah terhubung

R1#ping 172.30.2.2 (R2)
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.30.2.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/7/24 ms
R1#ping 192.168.4.9 (R2)
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.4.9, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 10/18/20 ms
R1#ping 192.168.4.10 (R3)
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.4.10, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 33/38/40 ms
2.     Melakukan test koneksi pada ketiga PC apakah sudah terhubung.
PC1 ke PC2,  PC1 ke PC2, PC1 ke PC3

Hasil Praktikum

Setelah konfigurasi telah dilakukan seperti inilah hasilnya :
     Menverifikasi semua routing sudah masuk dan mengetahui informasi pada router dengan   menggunakan command "show ip route", "show ip protocols", "debug ip rip".

R1#show ip route
    Gateway of last resort is not set
           172.30.0.0/24 is subnetted, 3 subnets
     C       172.30.1.0 is directly connected, FastEthernet0/0
     C       172.30.2.0 is directly connected, Serial0/0/0
     R       172.30.3.0 [120/1] via 172.30.2.2, 00:00:28, Serial0/0/0
     R    192.168.4.0/24 [120/1] via 172.30.2.2, 00:00:28, Serial0/0/0
     R    192.168.5.0/24 [120/2] via 172.30.2.2, 00:00:28, Serial0/0/0
R1#show ip protocols
  Default version control: send version 1, receive any version
  Interface             Send  Recv  Triggered RIP  Key-chain
  Serial0/0/0           1     2 1
Automatic network summarization is in effect
Maximum path: 4
Routing for Networks:
            172.30.0.0
            192.168.1.0
            192.168.2.0
Passive Interface(s):
            FastEthernet0/0
Routing Information Sources:
            Gateway         Distance      Last Update
            172.30.2.2           120      00:00:18
R1#debug ip rip
RIP protocol debugging is on
R1#RIP: sending  v1 update to 255.255.255.255 via Serial0/0/0 (172.30.2.1)
RIP: build update entries
      network 172.30.1.0 metric 1
RIP: received v1 update from 172.30.2.2 on Serial0/0/0
      172.30.3.0 in 1 hops
      192.168.4.0 in 1 hops
      192.168.5.0 in 2 hops
R2#show ip route
Gateway of last resort is not set
     172.30.0.0/24 is subnetted, 3 subnets
R       172.30.1.0 [120/1] via 172.30.2.1, 00:00:16, Serial0/0/0
C       172.30.2.0 is directly connected, Serial0/0/0
C       172.30.3.0 is directly connected, FastEthernet0/0
     192.168.4.0/30 is subnetted, 1 subnets
C       192.168.4.8 is directly connected, Serial0/0/1
R    192.168.5.0/24 [120/1] via 192.168.4.10, 00:00:15, Serial0/0/1
R2#show ip protocols
Routing Protocol is "rip"
Sending updates every 30 seconds, next due in 20 seconds
Invalid after 180 seconds, hold down 180, flushed after 240
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Redistributing: rip
Default version control: send version 1, receive any version
  Interface             Send  Recv  Triggered RIP  Key-chain
  Serial0/0/1           1     2 1
  Serial0/0/0           1     2 1
Automatic network summarization is in effect
Maximum path: 4
Routing for Networks:
            172.30.0.0
            192.168.2.0
            192.168.3.0
            192.168.4.0
Passive Interface(s):
            FastEthernet0/0
Routing Information Sources:
            Gateway         Distance      Last Update
            172.30.2.1           120      00:00:14
            192.168.4.10         120      00:00:07
R2#debug ip rip
RIP protocol debugging is on
R2#RIP: received v1 update from 192.168.4.10 on Serial0/0/1
      192.168.5.0 in 1 hops
RIP: sending  v1 update to 255.255.255.255 via Serial0/0/1 (192.168.4.9)
RIP: build update entries
      network 172.30.0.0 metric 1
RIP: sending  v1 update to 255.255.255.255 via Serial0/0/0 (172.30.2.2)
RIP: build update entries
      network 172.30.3.0 metric 1
      network 192.168.4.0 metric 1
      network 192.168.5.0 metric 2
RIP: received v1 update from 172.30.2.1 on Serial0/0/0
      172.30.1.0 in 1 hops
R3#show ip protocols
    Default version control: send version 1, receive any version
    Interface             Send  Recv  Triggered RIP  Key-chain
    Serial0/0/1           1     2 1
    Automatic network summarization is in effect
    Maximum path: 4
    Routing for Networks:
            192.168.0.0
            192.168.4.0
            192.168.5.0
    Passive Interface(s):
            FastEthernet0/0
    Routing Information Sources:
            Gateway         Distance      Last Update
            192.168.4.9          120      00:00:01
R3#debug ip rip
RIP protocol debugging is on
R3#RIP: sending  v1 update to 255.255.255.255 via Serial0/0/1 (192.168.4.10)
RIP: build update entries
      network 192.168.5.0 metric 1
RIP: received v1 update from 192.168.4.9 on Serial0/0/1

      172.30.0.0 in 1 hops

Selasa, 18 Juni 2013

Lab 4.4.1: Basic VTP Configuration

Laporan
Lab 4.4.1: Basic VTP Configuration

Nama    : Markhamah Tri Utami
NIM      : 12 615 056

Learning Objectives
  • Perform basic switch configurations
  • Configure the Ethernet interfaces on the host PCs
  • Configure VTP and security on the switches




Task 1: Perform Basic Switch Configurations
Configure the S1, S2, and S3 switches according to the following guidelines and save all your configurations:
  • Configure the switch hostname as indicated on the topology.
  • Disable DNS lookup.
  • Configure an EXEC mode password of class.
  • Configure a password of cisco for console connections.
  • Configure a password of cisco for vty connections.
Switch>enable
Switch#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#hostname S1
S1(config)#enable secret class
S1(config)#no ip domain-lookup
S1(config)#line console 0
S1(config-line)#password cisco
S1(config-line)#login
S1(config-line)#line vty 0 15
S1(config-line)#password cisco
S1(config-line)#login
S1(config-line)#end
%SYS-5-CONFIG_I: Configured from console by console
S1#copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]

Task 2: Configure the Ethernet Interfaces on the Host PCs

Configure the Ethernet interfaces of PC1, PC2, PC3, PC4, PC5, and PC6 with the IP addresses and default gateways indicated in the addressing table.

Task 3: Configure VTP and Security on the Switches

Step 1. Enable the user ports on S2 and S3.

Configure the user ports in access mode. Refer to the topology diagram to determine which ports are connected to end-user devices.
S2(config)#interface fa0/6
S2(config-if)#switchport mode access
S2(config-if)#no shutdown
S2(config-if)#interface fa0/11
S2(config-if)#switchport mode access
S2(config-if)#no shutdown
S2(config-if)#interface fa0/18
S2(config-if)#switchport mode access
S2(config-if)#no shutdown

Step 2. Check the current VTP settings on the three switches.

Use the show vtp status command to determine the VTP operating mode for all three switches.
S1#show vtp status
VTP Version                     : 2
Configuration Revision          : 0
Maximum VLANs supported locally : 64
Number of existing VLANs        : 5
VTP Operating Mode              : Server
VTP Domain Name                 : 
VTP Pruning Mode                : Disabled
VTP V2 Mode                     : Disabled
VTP Traps Generation            : Disabled
MD5 digest                      : 0x7D 0x5A 0xA6 0x0E 0x9A 0x72 0xA0 0x3A 
Configuration last modified by 0.0.0.0 at 0-0-00 00:00:00
Local updater ID is 0.0.0.0 (no valid interface found)
 
S2#show vtp status
VTP Version                     : 2
Configuration Revision          : 0
Maximum VLANs supported locally : 64
Number of existing VLANs        : 5
VTP Operating Mode              : Server
VTP Domain Name                 : 
VTP Pruning Mode                : Disabled
VTP V2 Mode                     : Disabled
VTP Traps Generation            : Disabled
MD5 digest                      : 0x7D 0x5A 0xA6 0x0E 0x9A 0x72 0xA0 0x3A 
Configuration last modified by 0.0.0.0 at 0-0-00 00:00:00
Local updater ID is 0.0.0.0 (no valid interface found)
 
S3#show vtp status
VTP Version                     : 2
Configuration Revision          : 0
Maximum VLANs supported locally : 64
Number of existing VLANs        : 5
VTP Operating Mode              : Server
VTP Domain Name                 : 
VTP Pruning Mode                : Disabled
VTP V2 Mode                     : Disabled
VTP Traps Generation            : Disabled
MD5 digest                      : 0x7D 0x5A 0xA6 0x0E 0x9A 0x72 0xA0 0x3A 
Configuration last modified by 0.0.0.0 at 0-0-00 00:00:00
Local updater ID is 0.0.0.0 (no valid interface found)
VTP allows the network administrator to control the instances of VLANs on the network by creating VTP domains. Within each VTP domain, one or more switches are configured as VTP servers. VLANs are then created on the VTP server and pushed to the other switches in the domain. Common VTP configuration tasks are setting the operating mode, domain, and password. Note that all three switches are in server mode. Server mode is the default VTP mode for most Catalyst switches. In this activity, you will be using S1 as the VTP server, with S2 and S3 configured as VTP clients or in VTP transparent mode.

Step 3. Configure the operating mode, domain name, and VTP password on all three switches.

Set the VTP domain name to Lab4 and the VTP password to cisco on all three switches. Configure S1 in server mode, S2 in client mode, and S3 in transparent mode.
S1(config)#vtp mode server
Device mode already VTP SERVER.
S1(config)#vtp domain Lab4
Changing VTP domain name from NULL to Lab4
S1(config)#vtp password cisco
Setting device VLAN database password to cisco
S1(config)#end 
 
S2(config)#vtp mode client
Setting device to VTP CLIENT mode
S2(config)#vtp domain Lab4
Changing VTP domain name from NULL to Lab4
S2(config)#vtp password cisco
Setting device VLAN database password to cisco
S2(config)#end 
 
S3(config)#vtp mode transparent
Setting device to VTP TRANSPARENT mode.
S3(config)#vtp domain Lab4
Changing VTP domain name from NULL to Lab4
S3(config)#vtp password cisco
Setting device VLAN database password to cisco
S3(config)#end 
Note: The VTP domain name can be learned by a client switch from a server switch, but only if the client switch domain is in the null state. It does not learn a new name if one has been previously set. For that reason, it is good practice to manually configure the domain name on all switches to ensure that the domain name is configured correctly. Switches in different VTP domains do not exchange VLAN information.

Step 4. Configure trunking and the native VLAN for the trunking ports on all three switches.

On all switches, configure trunking and the native VLAN for FastEthernet interfaces 0/1-5. Only commands for fa0/1 on each switch are shown below.
S1(config)#interface fa0/1
S1(config-if)#switchport mode trunk
S1(config-if)#switchport trunk native vlan 99
S1(config-if)#no shutdown
S1(config-if)#interface fa0/2
S1(config-if)#switchport mode trunk
S1(config-if)#switchport trunk native vlan 99
S1(config-if)#no shutdown
S1(config-if)#end
 
S2(config)#interface fa0/1
S2(config-if)#switchport mode trunk
S2(config-if)#switchport trunk native vlan 99
S2(config-if)#no shutdown
S2(config-if)#end
 
S3(config)#interface fa0/2
S3(config-if)#switchport mode trunk
S3(config-if)#switchport trunk native vlan 99
S3(config-if)#no shutdown
S3(config-if)#end

Step 5. Configure port security on the S2 and S3 access layer switches.

Configure ports fa0/6, fa0/11, and fa0/18 so that they allow only a single host and learn the MAC address of the host dynamically.
S2(config)#interface fa0/6
S2(config-if)#switchport port-security 
S2(config-if)#switchport port-security maximum 1
S2(config-if)#switchport port-security mac-address sticky 
S2(config-if)#interface fa0/11
S2(config-if)#switchport port-security 
S2(config-if)#switchport port-security maximum 1
S2(config-if)#switchport port-security mac-address sticky 
S2(config-if)#interface fa0/18 
S2(config-if)#switchport port-security 
S2(config-if)#switchport port-security maximum 1
S2(config-if)#switchport port-security mac-address sticky 
S2(config-if)#end
 
S3(config)#interface fa0/6
S3(config-if)#switchport port-security 
S3(config-if)#switchport port-security maximum 1
S3(config-if)#switchport port-security mac-address sticky 
S3(config-if)#interface fa0/11
S3(config-if)#switchport port-security 
S3(config-if)#switchport port-security maximum 1
S3(config-if)#switchport port-security mac-address sticky 
S3(config-if)#interface fa0/18 
S3(config-if)#switchport port-security 
S3(config-if)#switchport port-security maximum 1
S3(config-if)#switchport port-security mac-address sticky 
S3(config-if)#end

Step 6. Configure VLANs on the VTP server.

There are four VLANS required in this lab:
  • VLAN 99 (management)
  • VLAN 10 (faculty/staff)
  • VLAN 20 (students)
  • VLAN 30 (guest)
Configure these on the VTP server. Packet Tracer grading is case-sensitive.
S1(config)#vlan 99
S1(config-vlan)#name management
S1(config-vlan)#exit
S1(config)#vlan 10
S1(config-vlan)#name faculty/staff
S1(config-vlan)#exit
S1(config)#vlan 20 
S1(config-vlan)#name students
S1(config-vlan)#exit
S1(config)#vlan 30
S1(config-vlan)#name guest
S1(config-vlan)#exit
Verify that the VLANs have been created on S1 with the show vlan brief command.

Step 7. Check if the VLANs created on S1 have been distributed to S2 and S3.

Use the show vlan brief command on S2 and S3 to determine if the VTP server has pushed its VLAN configuration to all the switches.
S2#show vlan brief
 
VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/1, Fa0/2, Fa0/4, Fa0/5
                                                Fa0/6, Fa0/7, Fa0/8, Fa0/9
                                                Fa0/10, Fa0/11, Fa0/12,Fa0/13
                                                Fa0/14, Fa0/15, Fa0/16,Fa0/17
                                                Fa0/18, Fa0/19, Fa0/20,Fa0/21
                                                Fa0/22, Fa0/23, Fa0/24, Gi0/1
                                                Gi0/2
10   faculty/staff                    active
20   students                         active
30   guest                            active
99   management                       active 
 
S3#show vlan brief
VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/1, Fa0/3, Fa0/4, Fa0/5
                                                Fa0/6, Fa0/7, Fa0/8, Fa0/9
                                                Fa0/10, Fa0/11, Fa0/12, Fa0/13
                                                Fa0/14, Fa0/15, Fa0/16, Fa0/17
                                                Fa0/18, Fa0/19, Fa0/20, Fa0/21
                                                Fa0/22, Fa0/23, Fa0/24, Gig1/1
                                                Gig1/2
1002 fddi-default                     active    
1003 token-ring-default               active    
1004 fddinet-default                  active    
1005 trnet-default                    active    
Are the same VLANs configured on all switches?
Why do S2 and S3 have different VLAN configurations at this point?

Step 8. Create a new VLAN on S2 and S3.

S2(config)#vlan 88
%VTP VLAN configuration not allowed when device is in CLIENT mode.
 
S3(config)#vlan 88
S3(config-vlan)#name test
S3(config-vlan)#
Why are you prevented from creating a new VLAN on S2 but not S3?
Delete VLAN 88 from S3.
S3(config)#no vlan 88

Step 9. Manually configure VLANs.

Configure the four VLANs identified in Step 6 on switch S3.
S3(config)#vlan 99
S3(config-vlan)#name management
S3(config-vlan)#exit
S3(config)#vlan 10
S3(config-vlan)#name faculty/staff
S3(config-vlan)#exit
S3(config)#vlan 20 
S3(config-vlan)#name students
S3(config-vlan)#exit
S3(config)#vlan 30
S3(config-vlan)#name guest
S3(config-vlan)#exit
Here you see one of the advantages of VTP. Manual configuration is tedious and error prone, and any error introduced here could prevent intra-VLAN communication. In addition, these types of errors can be difficult to troubleshoot.

Step 10. Configure the management interface address on all three switches.

S1(config)#interface vlan 99
S1(config-if)#ip address 172.17.99.11 255.255.255.0
S1(config-if)#no shutdown
S2(config)#interface vlan 99
S2(config-if)#ip address 172.17.99.12 255.255.255.0
S2(config-if)#no shutdown
S3(config)#interface vlan 99
S3(config-if)#ip address 172.17.99.13 255.255.255.0
S3(config-if)#no shutdown
Verify that the switches are correctly configured by pinging between them. From S1, ping the management interface on S2 and S3. From S2, ping the management interface on S3.
Were the pings successful? If not, troubleshoot the switch configurations and try again.

Step 11. Assign switch ports to VLANs.

Refer to the port assignment table at the beginning of the activity to assign ports to the VLANs. Since Packet Tracer 4.11 does not make use of the interface range command, only configure the first interface for each VLAN. Port assignments are not configured through VTP. Port assignments must be configured on each switch manually or dynamically using a VMPS server. The commands are shown for S3 only, but both S2 and S3 switches should be similarly configured. Save the configuration when you are done.
S3(config)#interface fa0/6
S3(config-if-range)#switchport access vlan 30
S3(config-if-range)#interface fa0/11
S3(config-if-range)#switchport access vlan 10
S3(config-if-range)#interface fa0/18
S3(config-if-range)#switchport access vlan 20
S3(config-if-range)#end
S3#copy running-config startup-config
Destination filename [startup-config]? [enter]
Building configuration...
[OK]
S3#

Hasil Praktikum
Komputer terhubung, untuk mengetahui dilakukan ping ke PC
PC1 ke PC4





PC2 ke PC5



PC3 ke PC 6